git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] config: add --repository option

From
Junio C Hamano <gitster@pobox.com>
Date
Jun 2, 2009, 15:29 UTC
Message-ID
<7vskiifyd5.fsf@alter.siamese.dyndns.org>
In-Reply-To
<20090602195555.6117@nanako3.lavabit.com>
Nanako Shiraishi <nanako3@lavabit.com> writes:
Show 15 quoted lines
> Quoting Sverre Rabbelier <srabbelier@gmail.com>:
>
>> This is a shorthand similar to --system but instead uses
>> the config file of the current repository.
>>
>> Signed-off-by: Sverre Rabbelier <srabbelier@gmail.com>
>> ---
>>
>> 	I often want to check what the local value of a config
>> 	entry is, hence this patch.
>>
>>  builtin-config.c |    7 +++++--
>>  1 files changed, 5 insertions(+), 2 deletions(-)
>
> Junio, may I ask what happened to this patch?
Nothing ;-)

I did see it, but simply forgot about it, as nobody else seemed to be interested nor found anything objectionable in it.

I somehow think --repository is much harder to type than --local, and in the context of the command, somehow --local would mesh better with other existing options --system and --global, but that comment falls into the bikeshedding category.

Previous: Nanako ShiraishiNext: Sverre Rabbelier
Message 3 of 4 in “config: add --repository option”
  1. config: add --repository optionSverre Rabbelier, May 9, 2009
  2. Nanako ShiraishiJun 2, 2009
  3. Junio C HamanoJun 2, 2009
  4. Sverre RabbelierJun 2, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.