git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] Add DEST Makefile variable

From
JHJunio C Hamano <junio@siamese.dyndns.org>
Date
Apr 21, 2005, 22:59 UTC
Message-ID
<7vr7h3d9cu.fsf@assigned-by-dhcp.cox.net>
In-Reply-To
<20050421123904.9F2EB7F8AD@smurf.noris.de>
>>>>> "MU" == Matthias Urlichs <smurf@smurf.noris.de> writes:
MU>  # (my ext3 doesn't).
MU>  CFLAGS=-g -O3 -Wall
MU> +DEST=$(HOME)/bin
 
MU>  install: $(PROG) $(GEN_SCRIPT)
MU> -	install $(PROG) $(SCRIPT) $(GEN_SCRIPT) $(HOME)/bin/
MU> +	install $(PROG) $(SCRIPT) $(GEN_SCRIPT) $(DEST)/
 
I sent essentially the same some time ago and got a comment to
follow established naming convention.

Many people seem to call What you are calling DEST above BINDIR and DEST or DESTDIR usually means something completely different. It goes like this:

    # DESTDIR=
    BINDIR=$(HOME)/bin
    install:
            install foobar $(DESTDIR)$(BINDIR)/
  $ su ;# personal machine install by local root
  # make BINDIR=/usr/local/bin install
  # binary package creation
  $ make BINDIR=/usr/bin DESTDIR=/var/tmp/tmp-inst install
  $ tar Ccf /var/tmp/tmp-inst tarball.tar.gz .
Previous: Matthias UrlichsNext: Matthias Urlichs
Message 2 of 4 in “Add DEST Makefile variable”
  1. Add DEST Makefile variableMatthias Urlichs, Apr 21, 2005
  2. Junio C HamanoApr 21, 2005
  3. Matthias UrlichsApr 21, 2005
  4. Pavel RoskinApr 21, 2005

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.