git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 1/8] Add new git-cc-cmd helper to contrib

From
Junio C Hamano <gitster@pobox.com>
Date
Apr 19, 2013, 19:56 UTC
Message-ID
<7vr4i6z448.fsf@alter.siamese.dyndns.org>
In-Reply-To
<CAMP44s2gA0JbfxA1UQW_pnizGBpmbQem3Qg0FpWP_Wi6eYwVjw@mail.gmail.com>
Felipe Contreras <felipe.contreras@gmail.com> writes:
Show 8 quoted lines
>> If this were _only_ to be used within send-email (i.e. replacing the
>> "then send it out" above with "then use send-email" to limit the
>> usecase), "git cc-cmd" would be a reasonable name.  But if that is
>> the intended use case, it would even be more reasonable to make this
>> logic part of send-email and trigger it with --auto-cc-reviewers
>> option or something.
>
> Yeap, but I wouldn't want to be the one that implements that in perl.
That is OK.  None of this has to be done by you.

And we seem to be in agreement that the feature deserves to be its own command, so it does not have to be in Perl, either.

Show 7 quoted lines
>> But I think it can be useful outside the context of send-email as
>> well, and having one independent tool that does one single job well
>> is a better design.  Perhaps it is better to name it less specific
>> to send-email's cc-cmd option.  "git people"?  "git whom"?  "git
>> reviewers"?  I dunno, but along those lines.
>
> 'git relevant'? 'git related'? It's not only people, also commits.

Let's let it simmer on the list for a few days so that other people can come up with a better name.

Previous: Felipe ContrerasNext: Johannes Sixt
Message 9 of 22 in “New git-cc-cmd helper”
  1. 0/8 New git-cc-cmd helperFelipe Contreras, Apr 19, 2013
  2. 1/8 Add new git-cc-cmd helper to contribFelipe Contreras, Apr 19, 2013
  3. Ramkumar RamachandraApr 19, 2013
  4. Felipe ContrerasApr 19, 2013
  5. Junio C HamanoApr 19, 2013
  6. Felipe ContrerasApr 19, 2013
  7. Junio C HamanoApr 19, 2013
  8. Felipe ContrerasApr 19, 2013
  9. Junio C HamanoApr 19, 2013
  10. Johannes SixtApr 19, 2013
  11. Junio C HamanoApr 20, 2013
  12. Jeremy RosenApr 22, 2013
  13. Junio C HamanoApr 19, 2013
  14. 2/8 contrib: cc-cmd: add option parsingFelipe Contreras, Apr 19, 2013
  15. 3/8 contrib: cc-cmd: add support for multiple patchesFelipe Contreras, Apr 19, 2013
  16. 4/8 contrib: cc-cmd: add option to show commitsFelipe Contreras, Apr 19, 2013
  17. 5/8 contrib: cc-cmd: add option to parse from committishFelipe Contreras, Apr 19, 2013
  18. Junio C HamanoApr 19, 2013
  19. Felipe ContrerasApr 19, 2013
  20. 6/8 contrib: cc-cmd: parse committish like format-patchFelipe Contreras, Apr 19, 2013
  21. 7/8 contrib: cc-cmd: fix parsing of rev-list argsFelipe Contreras, Apr 19, 2013
  22. 8/8 contrib: cc-cmd: add option to fetch aliasesFelipe Contreras, Apr 19, 2013

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.