Re: [PATCH] tests: Introduce test_seq
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 4, 2012, 23:05 UTC
- Message-ID
- <7vpq768dhw.fsf@alter.siamese.dyndns.org>
- In-Reply-To
- <501D4FF0.4060109@kdbg.org>
Johannes Sixt <j6t@kdbg.org> writes:
Show 10 quoted lines
> And the reason for this is that we always told people "don't use seq" > and they submitted an updated patch. What would we have to do now? We > have to tell them "don't use seq, use test_seq". Therefore, the patch > does not accomplish anything useful, IMO. > > The function should really just be named 'seq'. > > Or how about this strategy: > ... > but it is not my favorite.
Why not? That implementation looks like a logical and natural consequence of "should relly just be named 'seq'" suggestion.
Having said that, we already say "don't use cmp, use test_cmp", so it might not be such a big deal, even though I find the reasoning in the first paragraph I quoted above from your message quite sane and convincing to me.