Re: [PATCH 1/2] gitview: Fix the blame interface.
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jun 13, 2007, 04:58 UTC
- Message-ID
- <7vmyz4h2nb.fsf@assigned-by-dhcp.pobox.com>
- In-Reply-To
- <11816697213806-git-send-email-aneesh.kumar@gmail.com>
"Aneesh Kumar K.V" <aneesh.kumar@gmail.com> writes:
Show 10 quoted lines
> @@ -401,7 +402,11 @@ class AnnotateWindow(object): > def data_ready(self, source, condition): > while (1): > try : > - buffer = source.read(8192) > + # A simple readline doesn't work > + # a readline bug ?? > + buffer="" > + buffer = source.read(100) > +
Are you sure about the first assignment?
Show 10 quoted lines
> @@ -419,7 +432,8 @@ class AnnotateWindow(object): > m = annotate_line.match(buff) > if not m: > continue > - filename = m.group(2) > + else: > + filename = m.group(2) > else: > self.commit_sha1 = m.group(1) > self.source_line = int(m.group(2))
The script is in contrib/ so I probably shouldn't be nitpicking, but for this particular hunk, I think (1) this is a no-op change, and (2) the original is easier to read.