Re: [PATCH] Make is_gitfile a non-static generic function
Phil Hord <phil.hord@gmail.com> writes:
Show 17 quoted lines
> On Tue, Oct 11, 2011 at 7:45 PM, Junio C Hamano <gitster@pobox.com> wrote:
>> After looking at this patch and the way the other caller in transport.c
>> uses it, I am more and more convinced that "is_gitfile()" is a stupid and
>> horrible mistake.
>
> I think I misunderstood your objection before. Now I think I
> understand. Tell me if I am right.
>
>
> I think you mean that instead of this:
> } else if (is_local(url) && is_file(url) && !is_gitfile(url)) {
>
> you would like to see this:
> } else if (is_local(url) && is_file(url) && is_bundle(url)) {
>
> Or maybe even this:
> } else if (is_bundle(url)) {