Re: [PATCH v2 2/4] xdiff/xprepare: refactor abort cleanups
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jul 6, 2011, 17:57 UTC
- Message-ID
- <7vliwbmgv0.fsf@alter.siamese.dyndns.org>
- In-Reply-To
- <1309970337-6016-3-git-send-email-rctay89@gmail.com>
Tay Ray Chuan <rctay89@gmail.com> writes:
> Group free()'s that are called when a malloc() fails in > xdl_prepare_ctx(), making for more readable code.
Nicer, but I wonder if we can get away with a single label that lets us abort with freeing whatever we have allocated by making sure that the various pointer fields and variables are initialized to NULL, which may lead to even more readable code.