Re: [PATCH v3 1/2] Factor find_pack_entry()'s core out
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Feb 1, 2012, 22:03 UTC
- Message-ID
- <7vaa522oum.fsf@alter.siamese.dyndns.org>
- In-Reply-To
- <alpine.LFD.2.02.1202011056140.2759@xanadu.home>
Nicolas Pitre <nico@fluxnic.net> writes:
Show 6 quoted lines
>> +static int find_pack_entry_1(const unsigned char *sha1, >> + struct packed_git *p, struct pack_entry *e) > > This looks all goot but the name. Pretty please, try to find something > that is more descriptive than "1". Suggestions: > "find_pack_entry_lookup", "find_pack_entry_inner", etc.
Perhaps "find_pack_entry_in_pack(sha1, e, p)"? That would go well with the caller "find_pack_entry(sha1, e)".