Re: [RFC/PATCH 3/3] push: add 'prune' option
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Feb 22, 2012, 20:56 UTC
- Message-ID
- <7v8vjua8p9.fsf@alter.siamese.dyndns.org>
- In-Reply-To
- <CAMP44s3+XCM1E_AtW1yGifmGoGSkFSpSTaFbbMffz+hmUzWahw@mail.gmail.com>
Felipe Contreras <felipe.contreras@gmail.com> writes:
>> Perhaps "enum map_direction { SRC_TO_DST, DST_TO_SRC }" or something?
>
> I think only FROM_SRC, FROM_DST is more than enough to figure it out.Yeah, as you can tell from my "or something", as long as the name makes the direction clear, I don't care too much about the exact spelling.
Show 6 quoted lines
>> Perhaps rename this to "map_push_refs()" or something in the patch 2/3? > > I think get_ref_match() would be more appropriate because we are > acting on a specific (singular) ref, and the primary thing we care > about is getting the peer name, based on the refspec match, which we > might want as a return value.
Again, as long as the name makes it clear this is meant only for "push" and never be used for "fetch", I am fine with it. One way to make it sure is to have a substring "_push" somewhere in that name.
> Probably some rebase mistake =/
Thanks; I was wondering if there is something subtle unexplained going on.