Re: [PATCH 0/8 v6] diff --stat: use the full terminal width
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Feb 20, 2012, 23:41 UTC
- Message-ID
- <7v4nuljcnk.fsf@alter.siamese.dyndns.org>
- In-Reply-To
- <1329775034-21551-1-git-send-email-zbyszek@in.waw.pl>
Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> writes:
Show 8 quoted lines
> JC: >> Perhaps the maximum for garph_width should be raised to something like >> "min(80, stat_width) - name_width"? > I think that a graph like > a | 1000 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ > b | 1 - > is not very readable. I like the consistency forced by the 40-column limit. > But I guess that this is very subjective.
The above makes it very obvious that there is a huge amount of change made to 'a' and a bit of deletion to 'b', compared to a mini-graph that is truncated to half the screen width.
Besides, the above is what you would get without your patch on 80-column terminal, no?