git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v5 08/10] rebase -i: skip unnecessary picks using the rebase--helper

From
Liam Beguin <liambeguin@gmail.com>
Date
Jun 20, 2017, 02:35 UTC
Message-ID
<7e5cd36f-772e-b73e-12cd-d52878bdf52c@gmail.com>
In-Reply-To
<alpine.DEB.2.21.1.1706191127450.57822@virtualbox>
On 19/06/17 05:45 AM, Johannes Schindelin wrote:
Show 106 quoted lines
> Hi Liam,
> 
> On Sat, 17 Jun 2017, Liam Beguin wrote:
> 
>> On 16/06/17 09:56 AM, Johannes Schindelin wrote:
>>
>>> On Thu, 15 Jun 2017, Liam Beguin wrote:
>>>
>>>> On 14/06/17 09:08 AM, Johannes Schindelin wrote:
>>>>> diff --git a/sequencer.c b/sequencer.c
>>>>> index a697906d463..a0e020dab09 100644
>>>>> --- a/sequencer.c
>>>>> +++ b/sequencer.c
>>>>> @@ -2640,3 +2640,110 @@ int check_todo_list(void)
>>>>>  
>>>>>  	return res;
>>>>>  }
>>>>> +
>>>>> +/* skip picking commits whose parents are unchanged */
>>>>> +int skip_unnecessary_picks(void)
>>>>> +{
>>>>> +	const char *todo_file = rebase_path_todo();
>>>>> +	struct strbuf buf = STRBUF_INIT;
>>>>> +	struct todo_list todo_list = TODO_LIST_INIT;
>>>>> +	struct object_id onto_oid, *oid = &onto_oid, *parent_oid;
>>>>> +	int fd, i;
>>>>> +
>>>>> +	if (!read_oneliner(&buf, rebase_path_onto(), 0))
>>>>> +		return error(_("could not read 'onto'"));
>>>>> +	if (get_sha1(buf.buf, onto_oid.hash)) {
>>>>
>>>> I missed this last time but we could also replace `get_sha1` with
>>>> `get_oid`
>>>
>>> Good point!
>>>
>>> I replaced this locally and force-pushed, but there is actually little
>>> chance of this patch series being integrated in a form with which I
>>> would be comfortable.
>>
>> Is there any chance of this moving forward? I was hoping to resend my
>> path to abbreviate command names on top of this.
> 
> We are at an impasse right now.
> 
> Junio wants me to change this code:
> 
>         revs.pretty_given = 1;
>         git_config_get_string("rebase.instructionFormat", &format);
>         if (!format || !*format) {
>                 free(format);
>                 format = xstrdup("%s");
>         }
>         get_commit_format(format, &revs);
>         free(format);
>         pp.fmt = revs.commit_format;
>         pp.output_encoding = get_log_output_encoding();
> 
>         if (setup_revisions(argc, argv, &revs, NULL) > 1)
> 	...
> 
> which is reasonably compile-time safe, to something like this:
> 
> 	struct strbuf userformat = STRBUF_INIT;
> 	struct argv_array args = ARGV_ARRAY_INIT;
> 	...
> 	for (i = 0; i < argc; i++)
> 		argv_array_push(&args, argv[i]);
>         git_config_get_string("rebase.instructionFormat", &format);
>         if (!format || !*format)
> 		argv_array_push(&args, "--format=%s");
> 	else {
> 		strbuf_addf(&userformat, "--format=%s", format);
>                 argv_array_push(&args, userformat.buf);
>         }
> 
>         if (setup_revisions(args.argc, args.argv, &revs, NULL) > 1)
> 	...
> 	argv_array_clear(&args);
> 	strbuf_release(&userformat);
> 
> which is not compile-time safe, harder to read, sloppy coding in my book.
> 
> The reason for this suggestion is that one of the revision machinery's
> implementation details is an ugly little semi-secret: the pretty-printing
> machinery uses a global state, and that is why we need the "pretty_given"
> flag in the first place.
> 
> Junio thinks that it would be better to not use the pretty_given flag in
> this patch series. I disagree: It would be better to use the pretty_given
> flag, also as a good motivator to work on removing the global state in the
> pretty-printing machinery.
> 
> Junio wants to strong-arm me into accepting authorship for this sloppy
> coding, and I simply won't do it.
> 
> That's why we are at an impasse right now.
> 
> I am really, really sorry that this affects your patch series, as I had
> not foreseen Junio's insistence on the sloppy coding when I suggested that
> you rebase your work on top of my patch series. I just was really
> unprepared for this contention, and I am still surprised/shocked that this
> is even an issue up for discussion.
> 
> Be that as it may, I see that this is a very bad experience for a
> motivated contributor such as yourself. I am very sorry about that!

It's not such a bad experience, I've found the people on the list to be quite welcoming and supportive.

> 
> So it may actually be better for you to go forward with your original
> patch series targeting git-rebase--interactive.sh.

I'll wait a bit longer to see how this goes and if it doesn't move, I'll try re-sending an update to that series.

> 
> My apologies,
> Dscho
> 

Thanks, Liam

Previous: Junio C HamanoNext: Johannes Schindelin
Message 16 of 20 in “The final building block for a faster rebase -i”
  1. 00/10 The final building block for a faster rebase -iJohannes Schindelin, Jun 14, 2017
  2. 02/10 rebase -i: generate the script via rebase--helperJohannes Schindelin, Jun 14, 2017
  3. 01/10 t3415: verify that an empty instructionFormat is handled as beforeJohannes Schindelin, Jun 14, 2017
  4. 03/10 rebase -i: remove useless indentationJohannes Schindelin, Jun 14, 2017
  5. 04/10 rebase -i: do not invent onelines when expanding/collapsing SHA-1sJohannes Schindelin, Jun 14, 2017
  6. 05/10 rebase -i: also expand/collapse the SHA-1s via the rebase--helperJohannes Schindelin, Jun 14, 2017
  7. 06/10 t3404: relax rebase.missingCommitsCheck testsJohannes Schindelin, Jun 14, 2017
  8. 07/10 rebase -i: check for missing commits in the rebase--helperJohannes Schindelin, Jun 14, 2017
  9. 08/10 rebase -i: skip unnecessary picks using the rebase--helperJohannes Schindelin, Jun 14, 2017
  10. Liam BeguinJun 16, 2017
  11. Johannes SchindelinJun 16, 2017
  12. Liam BeguinJun 17, 2017
  13. Johannes SchindelinJun 19, 2017
  14. Jeff KingJun 19, 2017
  15. Junio C HamanoJun 19, 2017
  16. Liam BeguinJun 20, 2017
  17. 09/10 t3415: test fixup with wrapped onelineJohannes Schindelin, Jun 14, 2017
  18. 10/10 rebase -i: rearrange fixup/squash lines using the rebase--helperJohannes Schindelin, Jun 14, 2017
  19. Junio C HamanoJun 15, 2017
  20. Johannes SchindelinJun 16, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.