Re: [PATCH RFC v2 2/2] Move libgit.a sources into separate "lib/" directory
- From
Kaartic Sivaraam <kaartic.sivaraam@gmail.com>
- Date
- Jul 6, 2026, 04:29 UTC
- Message-ID
- <7d00e3e0-27f7-4d54-8985-ba7b670efcfb@gmail.com>
- In-Reply-To
- <akX1TMoRr87Id8Ss@pks.im>
On 02/07/26 10:51, Patrick Steinhardt wrote:
Show 14 quoted lines
> On Wed, Jul 01, 2026 at 07:45:09AM -0700, Junio C Hamano wrote: >> Phillip Wood <phillip.wood123@gmail.com> writes: >> >>> Another cost is remembering things have moved - the other day I spent >>> too long wondering why "git show origin/seen:wt-status.c" wasn't working >>> until I ran "git log origin/seen" and realized it had move to >>> lib/wt-status.c. >> >> Yes, this has bit me multiple dozen times, as the tip of 'seen' is >> contaminated with this rename, already. It is a huge pain. > > Yeah, this one I don't have any arguments against besides a very > hand-wavy "it'll get better over time" :) >
On a bit of a tangent, this made me wonder if it would be helpful to make a potential improvement to 'git show' UX that shows a hint that the file asked to be shown was moved as part of a recent rename.
Something like:
$ git show origin/seen:wt-status.c fatal: path 'wt-status.c' does not exist in 'origin/seen' hint: 'wt-status.c' appears to have been renamed to 'builtin/wt-status.c' in 'origin/seen' hint: Did you mean 'origin/seen:builtin/wt-status.c'? hint: Disable this message with "git config advice.objectNameWarning false"
Finding rename just to show a hint sounds a bit too much work for a hint. I wonder if it would worth given the better UX, though.
-- Sivaraam