git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 1/2] python file more pytonic, adjust "if" and "for"

From
DGdsal3389 via GitGitGadget <gitgitgadget@gmail.com>
Date
Oct 6, 2022, 11:45 UTC
Message-ID
<71da6f53a44cd3390d122ff2c0446824313e5101.1665056747.git.gitgitgadget@gmail.com>
In-Reply-To
<pull.1355.git.git.1665056747.gitgitgadget@gmail.com>
From: dsal3389 <dsal3389@gmail.com>

L371 redesign few lines to get rid of the "else" statement

L404 moved the if statement below another if statement that checks if it should exit the code, only if it doesnt need to, then we can iterate the for loop and decode the text

Changes to be committed:
	modified:   git-p4.py
Signed-off-by: Daniel Sonbolian <dsal3389@gmail.com>
---
 git-p4.py | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)
diff --git a/git-p4.py b/git-p4.py
index d26a980e5ac..0ba5115fa2e 100755
--- a/git-p4.py
+++ b/git-p4.py
@@ -368,10 +368,9 @@ def read_pipe(c, ignore_error=False, raw=False, *k, **kw):
        """
     retcode, out, err = read_pipe_full(c, *k, **kw)
     if retcode != 0:
-        if ignore_error:
-            out = ""
-        else:
+        if not ignore_error:
             die('Command failed: {}\nError: {}'.format(' '.join(c), err))
+        out = ""
     if not raw:
         out = decode_text_stream(out)
     return out
@@ -400,10 +399,10 @@ def read_pipe_lines(c, raw=False, *k, **kw):
     p = subprocess.Popen(c, stdout=subprocess.PIPE, *k, **kw)
     pipe = p.stdout
     lines = pipe.readlines()
-    if not raw:
-        lines = [decode_text_stream(line) for line in lines]
     if pipe.close() or p.wait():
         die('Command failed: {}'.format(' '.join(c)))
+    if not raw:
+        lines = [decode_text_stream(line) for line in lines]
     return lines
 
 
-- 
gitgitgadget
Previous: dsal3389 via GitGitGadgetNext: Victoria Dye
Message 2 of 15 in “Minor Refactors: remove useless else”
  1. 0/2 Minor Refactors: remove useless elsedsal3389 via GitGitGadget, Oct 6, 2022
  2. 1/2 python file more pytonic, adjust "if" and "for"dsal3389 via GitGitGadget, Oct 6, 2022
  3. Victoria DyeOct 6, 2022
  4. Junio C HamanoOct 6, 2022
  5. 2/2 removed else statementdsal3389 via GitGitGadget, Oct 6, 2022
  6. Victoria DyeOct 6, 2022
  7. Junio C HamanoOct 7, 2022
  8. Junio C HamanoOct 6, 2022
  9. Junio C HamanoOct 6, 2022
  10. 0/2 git.c: improve readability | git-p4: minor optimizationDaniel Sonbolian via GitGitGadget, Oct 7, 2022
  11. 1/2 git-p4: minor optimization in read_pip_linesDaniel Sonbolian via GitGitGadget, Oct 7, 2022
  12. Phillip WoodOct 7, 2022
  13. Junio C HamanoOct 7, 2022
  14. 2/2 git.c: improve code readability in cmd_mainDaniel Sonbolian via GitGitGadget, Oct 7, 2022
  15. git.c: improve code readability in cmd_mainDaniel Sonbolian via GitGitGadget, Oct 8, 2022

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.