git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: BUG: "cherry-pick A..B || git reset --hard OTHER"

From
Stephan Beyer <s-beyer@gmx.net>
Date
Dec 9, 2016, 19:28 UTC
Message-ID
<6ee77e7d-b93e-107b-c3fb-519790453b59@gmx.net>
In-Reply-To
<e0780f7c-ccb4-29fe-3d72-80e45a202f65@gmx.net>
On 12/09/2016 08:24 PM, Stephan Beyer wrote:
> t3510 also shows another use-case for --quit: the title says it all:
> "cherry-pick --quit" to "cherry-pick --abort"

I should've read what I actually pasted. I wanted to paste: '--quit keeps HEAD and conflicted index intact'

Sorry for making no sense ;)
> With this additional information, I'd vote to keep --quit/--forget and
> just make it consistent.
Now!
~Stephan
Previous: Stephan BeyerNext: Duy Nguyen
Message 12 of 15 in “BUG: "cherry-pick A..B || git reset --hard OTHER"”
  1. Junio C HamanoDec 6, 2016
  2. Christian CouderDec 7, 2016
  3. Stephan BeyerDec 7, 2016
  4. Junio C HamanoDec 7, 2016
  5. Stephan BeyerDec 7, 2016
  6. Duy NguyenDec 7, 2016
  7. Duy NguyenDec 9, 2016
  8. rebase: rename --forget to be consistent with sequencerNguyễn Thái Ngọc Duy, Dec 9, 2016
  9. revert, cherry-pick: rename --quit to be consistent with rebaseNguyễn Thái Ngọc Duy, Dec 9, 2016
  10. Junio C HamanoDec 9, 2016
  11. Stephan BeyerDec 9, 2016
  12. Stephan BeyerDec 9, 2016
  13. Duy NguyenDec 10, 2016
  14. Junio C HamanoDec 10, 2016
  15. Christian CouderDec 8, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.