Re: [PATCH 5/7] xdiff: rename XDL_MERGE_STYLE_DIFF3
- From
Felipe Contreras <felipe.contreras@gmail.com>
- Date
- Jun 10, 2021, 13:33 UTC
- Message-ID
- <60c214ace1191_b25b12086e@natae.notmuch>
- In-Reply-To
- <3168eb15-25a6-a3eb-a498-8effa0c79855@gmail.com>
Phillip Wood wrote:
> On 09/06/2021 20:28, Felipe Contreras wrote: > > The subject would make more sense as 'xdiff: rename XDL_MERGE_DIFF3 to > XDL_MERGE_STYLE_DIFF3' rather than using the new name of the constant alone.
That is 55 characters, more than the recommended commit title length.
Show 6 quoted lines
> > If we don't specify we are talking about a style, XDL_MERGE_MINIMAL > > could be confused with a valid value instead of XDL_MERGE_DIFF3, which > > it isn't. > > I don't object to the rename but what is the source of the confusion > with XDL_MERGE_MINIMAL?
XDL_MERGE_MINIMAL and other XDL_MERGE_FOO constants go into xmparam_t.level, XDL_MERGE_DIFF3 does not.
As stated in the commit message, the name XDL_MERGE_DIFF3 doesn't distinguish it as a style.
Chers.
-- Felipe Contreras