Re: [PATCH v2 4/8] status: per-file data collection for --porcelain=v2
- From
- Jeff Hostetler <git@jeffhostetler.com>
- Date
- Jul 26, 2016, 13:31 UTC
- Message-ID
- <5797663A.5000507@jeffhostetler.com>
- In-Reply-To
- <xmqq1t2h5vbt.fsf@gitster.mtv.corp.google.com>
On 07/25/2016 04:14 PM, Junio C Hamano wrote:
Show 21 quoted lines
> Jeff Hostetler <jeffhost@microsoft.com> writes:
>
>> +static void aux_updated_entry_porcelain_v2(
>> + struct wt_status *s,
>> + struct wt_status_change_data *d,
>> + struct diff_filepair *p)
>> +{
>> + switch (p->status) {
>> + case DIFF_STATUS_ADDED:
>> + /* {mode,sha1}_head are zero for an add. */
>> + d->aux.porcelain_v2.mode_index = p->two->mode;
>
> I doubt that it makes sense in the longer term to have a new "aux"
> field. Why isn't it part of the wt_status_change_data structure?
> For that matter, why should these new functions have both "aux" and
> "v2" in their names?
>
> Imagine what should happen when somebody wants to add --porcelain=v3
> format in 6 months. Why must "v3" be treated differently from "v1"
> and in a way close to "v2"? Why shouldn't all the three be treated
> in a similar way that "v1" has already?I wasn't sure if we wanted the v2 fields to be isolated and only filled in for v2 requests or whether we wanted them to be common going forward. In the case of the former, I could see the "aux" struct becoming a union and the various aux_*() routines only populating one member in that union. And then the various per-format print routines would know which aux member to access. That may be more complicated that necessary though -- if we assume that any subsequent formats (and possibly any JSON formats) would always want to keep these fields and add more.
I'll flatten the fields into the main structure.
Show 19 quoted lines
>
>> + oidcpy(&d->aux.porcelain_v2.oid_index, &p->two->oid);
>> + break;
>> +
>> + case DIFF_STATUS_DELETED:
>> + d->aux.porcelain_v2.mode_head = p->one->mode;
>> + oidcpy(&d->aux.porcelain_v2.oid_head, &p->one->oid);
>> + /* {mode,oid}_index are zero for a delete. */
>> + break;
>> +
>> + case DIFF_STATUS_RENAMED:
>> + d->aux.porcelain_v2.rename_score = p->score * 100 / MAX_SCORE;
>
> I have a slight aversion against losing the precision in a helper
> function like this that does not do the actual output, but it
> probably is OK.
>
> Don't we have copy detection score that is computed exactly the same
> way for DIFF_STATUS_COPIED case, too?Yes I believe so. I'll see about adding that. Or rather make the field apply to both.
Show 6 quoted lines
> > For readability, unless a case arm is completely empty, we should > have > /* fallthru */ > > comment where "break;" would go for a normal case arm.
will do. thanks.