git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2] config: add '--sources' option to print the source of a config value

From
Ramsay Jones <ramsay@ramsayjones.plus.com>
Date
Feb 10, 2016, 12:47 UTC
Message-ID
<56BB3157.7080307@ramsayjones.plus.com>
In-Reply-To
<1455099198-11515-1-git-send-email-larsxschneider@gmail.com>
On 10/02/16 10:13, larsxschneider@gmail.com wrote:
Show 29 quoted lines
> From: Lars Schneider <larsxschneider@gmail.com>
> 
> If config values are queried using 'git config' (e.g. via '--list' flag
> or the '--get*' flags) then it is sometimes hard to find the
> configuration file where the values were defined.
> 
> Teach 'git config' the '--sources' option to print the source
> configuration file for every printed value.
> 
> Based-on-patch-by: Jeff King <peff@peff.net>
> Signed-off-by: Lars Schneider <larsxschneider@gmail.com>
> ---
> 
> diff to v1:
> 
> * add documention
> * produce a consistent (tab-delimited) format that can be parsed
> * adhere declaration-after-statement style
> * prefix every source line with the source type (file, stdin, blob, cmd)
> * add relative path test case
> * add blob ref test case
> * add "git config --local" test case (Note: I think I found a bug there that I
>   plan to fix/investigate in a seperate patch. Is it ok to leave the TODO?)
> * add a test case to check funny character escapes (file name with tabs)
> 
> Sebastian suggested "--show-origin" as a better option name over "--sources".
> I still believe "--sources" might be slightly better as I fear that users could
> somehow related "origin" to "remote" kind of configs. However, I am happy to
> change that if a majority prefers "--show-origin".

<bikeshed> As I have said before, I'm not very good at naming things, but ...

Of the two, I *slightly* prefer --show-origin, since I don't think there will be any confusion. However, I think --source may be OK too (for some reason it sounds better than the plural). Another idea may be --show-source. ;-)

</bikeshed>

ATB, Ramsay Jones

Previous: larsxschneider@gmail.comNext: Sebastian Schuberth
Message 2 of 10 in “config: add '--sources' option to print the source of a config value”
  1. config: add '--sources' option to print the source of a config valuelarsxschneider@gmail.com, Feb 10, 2016
  2. Ramsay JonesFeb 10, 2016
  3. Sebastian SchuberthFeb 10, 2016
  4. Ramsay JonesFeb 10, 2016
  5. Jeff KingFeb 10, 2016
  6. Sebastian SchuberthFeb 10, 2016
  7. Jeff KingFeb 10, 2016
  8. Sebastian SchuberthFeb 10, 2016
  9. Jeff KingFeb 10, 2016
  10. Eric SunshineFeb 10, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.