Re: [PATCH 3/4] create_symref: modernize variable names
- From
Michael Haggerty <mhagger@alum.mit.edu>
- Date
- Dec 28, 2015, 08:20 UTC
- Message-ID
- <5680F0DA.1020301@alum.mit.edu>
- In-Reply-To
- <20151220072949.GC30662@sigill.intra.peff.net>
On 12/20/2015 08:29 AM, Jeff King wrote:
Show 9 quoted lines
> Once upon a time, create_symref() was used only to point > HEAD at a branch name, and the variable names reflect that > (e.g., calling the path git_HEAD). However, it is much more > generic these days (and has been for some time). Let's > update the variable names to make it easier to follow: > > - `ref_target` is now just `ref`, matching the declaration > in `cache.h` (and hopefully making it clear that it is > the symref itself, and not the target).
I've been trying to name variables that hold reference names "refname" to distinguish them clearly from other representations of references, like "struct ref_entry *".
> [...]
Otherwise LGTM.
Michael
-- Michael Haggerty mhagger@alum.mit.edu