Re: [PATCH/RFC 0/3] --seed as an alias for --dissociate --reference
- From
Michael Haggerty <mhagger@alum.mit.edu>
- Date
- May 24, 2015, 23:53 UTC
- Message-ID
- <5562646A.1080608@alum.mit.edu>
- In-Reply-To
- <20150521041435.GA18978@peff.net>
Thanks for working on this. I have one little bikeshedding comment...
On 05/21/2015 06:14 AM, Jeff King wrote:
Show 7 quoted lines
> [...] > There are a few open issues with this series: > > 1. Assuming that "seed" is a reasonable verb for this concept, is > "--seed=<repo>" OK for the option? Would "--seed-from=<repo>" be > better? (Also, the response "bleh, seed is a terrible name" is > fine, too, but only if accompanied by your own suggestion :) ).
I think "seed" is a pretty good name. The only downside is that "seed" suggests that the process injects just a few seeds that are much smaller than the whole. But in fact, (hopefully) this option causes the bulk of the needed objects to be pre-fetched.
I can't think of any name that is clearly better. Some brainstorming:
* prepare -- meh * prime (as in "prime the pump"). But "prime" alone could have too many meanings, so... * prime-from * pre-fetch or pre-fetch-from * pre-load or pre-load-from
BTW I think "--seed-from=<repo>" is more self-explanatory than "--seed=<repo>".
Michael
-- Michael Haggerty mhagger@alum.mit.edu