[PATCH 3/3] submodule add: clean up duplicated code
- From
Jens Lehmann <jens.lehmann@web.de>
- Date
- Jun 6, 2011, 19:58 UTC
- Message-ID
- <4DED3173.20804@web.de>
- In-Reply-To
- <4DED30E0.6090608@web.de>
In cmd_add() the switch statement used to resolve a relative url was present twice. Remove the second one and use the realrepo variable set by the first one (lines 194 ff.) instead.
Signed-off-by: Jens Lehmann <Jens.Lehmann@web.de> --- git-submodule.sh | 10 +--------- 1 files changed, 1 insertions(+), 9 deletions(-)
diff --git a/git-submodule.sh b/git-submodule.sh index 3fbc21e..2a727e1 100755 --- a/git-submodule.sh +++ b/git-submodule.sh @@ -238,15 +238,7 @@ cmd_add() die "'$path' already exists and is not a valid git repo" fi - case "$repo" in - ./*|../*) - url=$(resolve_relative_url "$repo") || exit - ;; - *) - url="$repo" - ;; - esac - git config submodule."$path".url "$url" + git config submodule."$path".url "$realrepo" else module_clone "$path" "$realrepo" "$reference" || exit
-- 1.7.6.rc0.3.g28a66