Re: [PATCH 1/2] config: define and document exit codes
- From
Michael J Gruber <git@drmicha.warpmail.net>
- Date
- May 17, 2011, 15:49 UTC
- Message-ID
- <4DD2990A.8070400@drmicha.warpmail.net>
- In-Reply-To
- <BANLkTikjY956f7LxXGY5fcLkJJDuMnt6OQ@mail.gmail.com>
Thiago Farina venit, vidit, dixit 17.05.2011 17:46:
Show 9 quoted lines
> On Tue, May 17, 2011 at 12:38 PM, Michael J Gruber > <git@drmicha.warpmail.net> wrote: >> The return codes of git_config_set() and friends are magic numbers right >> in the source. #define them in cache.h where the functions are declared, > > Why defining them on cache.h? Just because the functions are declared > there? Is this a good reason? I think this pollute even more the > cache.h and these constants are not used outside of config.c. So I'd > move them back onto config.c. Maybe it's fine as is though.
Because, potentially, they are used by callers of these external functions. It's the interface declaration. And in fact, 2/2 creates such a use.
Michael