Re: Problem with large files on different OSes
- From
Andreas Ericsson <ae@op5.se>
- Date
- May 28, 2009, 08:52 UTC
- Message-ID
- <4A1E50D4.2010203@op5.se>
- In-Reply-To
- <279b37b20905272252i3d98b6bv698ff636d61ee058@mail.gmail.com>
Eric Raible wrote:
Show 21 quoted lines
> On Wed, May 27, 2009 at 9:30 PM, Shawn O. Pearce <spearce@spearce.org> wrote: >> Eric Raible <raible@gmail.com> wrote: >>> Nicolas Pitre <nico <at> cam.org> writes: >>>> On Wed, 27 May 2009, Linus Torvalds wrote: >>>> >>>>> +pack.packDeltaLimit:: >>>>> + The default maximum size of objects that we try to delta. >>>> The option name feels a bit wrong here, like if it meant the max number >>>> of deltas in a pack. Nothing better comes to my mind at the moment >>>> though. >>> pack.maxDeltaSize sounds weird when said aloud. >>> How about pack.deltaMaxSize? >> That sounds like, how big should a delta be? E.g. set it to 200 >> and any delta instruction stream over 200 bytes would be discarded, >> causing the whole object to be stored instead. Which is obviously >> somewhat silly, but that's the way I'd read that option... >> >> -- >> Shawn. > > You're right, that _is_ a strange color for the bike shed...
Since 'delta' names both the action and the result of the action, it's tricky to get it unambiguous without helping the grammar along a little.
pack.maxFileSizeToDelta
is probably the shortest we're going to get it while avoiding ambiguity.
-- Andreas Ericsson andreas.ericsson@op5.se OP5 AB www.op5.se Tel: +46 8-230225 Fax: +46 8-230231 Register now for Nordic Meet on Nagios, June 3-4 in Stockholm http://nordicmeetonnagios.op5.org/ Considering the successes of the wars on alcohol, poverty, drugs and terror, I think we should give some serious thought to declaring war on peace.