Re: [PATCH 3/3] pretty=format: Avoid some expensive calculations when not needed
- From
René Scharfe <rene.scharfe@lsrfire.ath.cx>
- Date
- Nov 7, 2007, 23:21 UTC
- Message-ID
- <4732487A.4050100@lsrfire.ath.cx>
- In-Reply-To
- <20071107001458.GE4382@artemis.corp>
Pierre Habouzit schrieb:
Show 15 quoted lines
> {
> const char *percent = strchrnul(fmt, '%');
> while (*percent) {
> strbuf_add(sb, fmt, percent - fmt);
> fmt = percent + 1;
>
> /* do your stuff */
>
> percent = strchrnul(fmt, '%');
> }
> strbuf_add(sb, fmt, percent - fmt);
> }
>
>
> Which would require strchrnul, but it's trivial compat/ material for sure.Grepping through the source I see several places that can be simplified by converting them to strchrnul(), so I think introducing this GNU extension is a good idea in any case.
Using strchr()/strchrnul() instead of strbuf_addch()'ing is sensible, of course. I don't like the duplicate code in your sketch above, though. I'll try to look into it later today.
Thanks! René