Re: [PATCH] Clarify the "cannot lock existing info/refs" error
- From
John Tapsell <johnflux@gmail.com>
- Date
- Mar 5, 2009, 08:00 UTC
- Message-ID
- <43d8ce650903050000g4466ab2fne5fb8ed009808346@mail.gmail.com>
- In-Reply-To
- <20090304192853.GA10567@localhost>
2009/3/4 Clemens Buchacher <drizzd@aon.at>:
Show 9 quoted lines
> On Wed, Mar 04, 2009 at 03:37:06PM +0000, John Tapsell wrote:
>> -fprintf(stderr, "Error: cannot lock existing info/refs\n");
>> +error("cannot lock existing info/refs on remote server\nPerhaps the
>> server is currently busy, or your ~/.netrc file is not configured
>> correctly.");
>
> In my experience this is usually caused by http-push crashing and leaving
> stale locks behind until it times out after 10 minutes. I don't think we
> should speculate here unless we can narrow down the error condition.Yeah, I was thinking of trying to narrow it down as well.
I personally get that error 3 out of 4 times, roughly, that I try to push. But that's probably because I'm using a very busy git server. So in my case, I just keep retrying until it succeeds.
On google I found that people had been getting that error if they have the wrong password.
Can we at least change it to:
-fprintf(stderr, "Error: cannot lock existing info/refs\n"); +error("cannot lock existing info/refs on remote server\n");
It's currently confusing as to whether it's a local error or a remote error.
John