git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 4/4] t5515: use `main` as the name of the main branch for testing (conclusion)

From
Johannes Schindelin via GitGitGadget <gitgitgadget@gmail.com>
Date
Nov 2, 2020, 23:55 UTC
Message-ID
<3704ecd9a82ae9d8fb705dd179b9ad2c9240d04d.1604361307.git.gitgitgadget@gmail.com>
In-Reply-To
<pull.761.git.1604361307.gitgitgadget@gmail.com>
From: Johannes Schindelin <johannes.schindelin@gmx.de>

In the previous three commits, We prepared the `t5515` script and the files in `t/t5515/` for the upcoming change of the default branch name to `main`. The changes were made over the course of three commits because the overall patch would have been too big to send to the Git mailing list for review.

Naturally, the test could not pass in the transitional stages and was therefore disabled via the `PREPARE_FOR_MAIN_BRANCH` prereq. Now that the transition is complete, we can re-enable it.

Signed-off-by: Johannes Schindelin <johannes.schindelin@gmx.de>
---
 t/t5515-fetch-merge-logic.sh | 7 +------
 1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/t/t5515-fetch-merge-logic.sh b/t/t5515-fetch-merge-logic.sh
index 1a81991cf7..50f14101c5 100755
--- a/t/t5515-fetch-merge-logic.sh
+++ b/t/t5515-fetch-merge-logic.sh
@@ -11,16 +11,11 @@ test_description='Merge logic in fetch'
 GIT_TEST_PROTOCOL_VERSION=0
 export GIT_TEST_PROTOCOL_VERSION
 
-GIT_TEST_DEFAULT_INITIAL_BRANCH_NAME=master
+GIT_TEST_DEFAULT_INITIAL_BRANCH_NAME=main
 export GIT_TEST_DEFAULT_INITIAL_BRANCH_NAME
 
 . ./test-lib.sh
 
-test_have_prereq PREPARE_FOR_MAIN_BRANCH || {
-	test_skip="In transit for the default branch name 'main'"
-	test_done
-}
-
 build_script () {
 	script="$1" &&
 	for i in one three_file main topic_2 one_tree three two two2 three2
-- 
gitgitgadget
Previous: Johannes Schindelin via GitGitGadgetNext: Johannes Schindelin via GitGitGadget
Message 4 of 6 in “Adjust t5515 for the upcoming change of the default branch name”
  1. 0/4 Adjust t5515 for the upcoming change of the default branch nameJohannes Schindelin via GitGitGadget, Nov 2, 2020
  2. 1/4 t5515: use `main` as the name of the main branch for testing (part 1)Johannes Schindelin via GitGitGadget, Nov 2, 2020
  3. 3/4 t5515: use `main` as the name of the main branch for testing (part 3)Johannes Schindelin via GitGitGadget, Nov 2, 2020
  4. 4/4 t5515: use `main` as the name of the main branch for testing (conclusion)Johannes Schindelin via GitGitGadget, Nov 2, 2020
  5. 2/4 t5515: use `main` as the name of the main branch for testing (part 2)Johannes Schindelin via GitGitGadget, Nov 2, 2020
  6. Junio C HamanoNov 3, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.