Re: test-mergesort conflict with stdlib.h
- From
Brian Gernhardt <brian@gernhardtsoftware.com>
- Date
- Apr 17, 2012, 18:09 UTC
- Message-ID
- <341E3693-9E1A-4356-A632-F5703E2829E8@gernhardtsoftware.com>
- In-Reply-To
- <7v8vhunsg5.fsf@alter.siamese.dyndns.org>
On Apr 17, 2012, at 2:06 PM, Junio C Hamano wrote:
Show 14 quoted lines
> Junio C Hamano <gitster@pobox.com> writes: > >> Unfortunate. OS X shouldn't contaminate the user namespace by adding such >> names in stdlib.h (which incidentally has qsort()), but the damage is done >> already, so I am not opposed to rename it to llist_mergesort() or something. > > Something like this. While we are touching the code, let's add some > documentation to the header. > > commit.c | 4 ++-- > mergesort.c | 8 ++++---- > mergesort.h | 16 ++++++++++++---- > test-mergesort.c | 2 +- > 4 files changed, 19 insertions(+), 11 deletions(-)
This is basically identical to what I was going to send and it does, in fact, fix my build problem.
Thanks, ~~ Brian Gernhardt