git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: What's cooking in git.git (Mar 2010, #06; Wed, 24)

From
BCBrandon Casey <brandon.casey.ctr@nrlssc.navy.mil>
Date
Mar 25, 2010, 16:27 UTC
Message-ID
<25yNvbuAivZlBuEJoRhXtfoEc7HEZorM5qOrwgQKk7FER_fdzljyMQ@cipher.nrlssc.navy.mil>
In-Reply-To
<fcaeb9bf1003250811g777b2881l332e6f61456d699@mail.gmail.com>
On 03/25/2010 10:11 AM, Nguyen Thai Ngoc Duy wrote:
Show 8 quoted lines
> 2010/3/25 Junio C Hamano <gitster@pobox.com>:
>> * ar/config-from-command-line (2010-03-19) 1 commit
>>  - Allow passing of configuration parameters in the command line
>>
>> * bc/t5505-fix (2010-03-19) 3 commits
>>  - t/t5505-remote.sh: escape * to prevent interpretation by shell as glob
>>  - t5505: add missing &&
>>  - t5505: remove unnecessary subshell invocations

methinks you were over-aggressive with your cut/paste? I don't think bc/t5505-fix contains a strndup. Hopefully, it does not break your build on Solaris.

> This breaks my build on Solaris because it uses strndup, which is not available.
A quick glance at ar/config-from.. also detected an unchecked calloc().
Alex, any reason xcalloc wasn't used?

btw, me also thinks the code is a little hard to read. For example, I initially thought your calloc was not allocating enough space for the nul terminator.

   ct = calloc(1, sizeof(struct config_item) + (text - name));
   memcpy(ct->name, name, text - name);

I traced the code, but it wasn't until I noticed that your data structure looks like this:

   struct config_item
   {
          struct config_item *next;
          char *value;
          char name[1];
   };

that I realized that room for the nul terminator in the 'name' array was allocated by the structure itself, since the name declaration looks like name[1] and not name[FLEX_ARRAY].

Would the code be simpler if strbufs were used? Then you wouldn't need to duplicate the skip_space and trailing_space functionality provided in the strbuf library, and would just need a new function named strbuf_tolower.

Also, should config_parametes_tail be spelled config_parameters_tail?
-brandon
Previous: Nguyen Thai Ngoc DuyNext: Alex Riesen
Message 3 of 13 in “What's cooking in git.git (Mar 2010, #06; Wed, 24)”
  1. Junio C HamanoMar 25, 2010
  2. Nguyen Thai Ngoc DuyMar 25, 2010
  3. Brandon CaseyMar 25, 2010
  4. Alex RiesenMar 25, 2010
  5. 1/2 Allow passing of configuration parameters in the command lineAlex Riesen, Mar 26, 2010
  6. 2/2 Use strbufs instead of open-coded string manipulationAlex Riesen, Mar 26, 2010
  7. Nguyen Thai Ngoc DuyMar 26, 2010
  8. Nguyen Thai Ngoc DuyMar 25, 2010
  9. Ben WaltonMar 26, 2010
  10. RPM spec: include bash completion supportIan Ward Comfort, Mar 26, 2010
  11. Ben WaltonMar 26, 2010
  12. Junio C HamanoMar 29, 2010
  13. Julian PhillipsMar 26, 2010

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.