Re: [PATCH 0/5] Start of a journey: drop NO_THE_INDEX_COMPATIBILITY_MACROS
- From
- Jeff Hostetler <git@jeffhostetler.com>
- Date
- May 2, 2017, 15:35 UTC
- Message-ID
- <253450f8-4ece-e31b-c139-5d8a3863fb9a@jeffhostetler.com>
- In-Reply-To
- <20170501190719.10669-1-sbeller@google.com>
On 5/1/2017 3:07 PM, Stefan Beller wrote:
Show 14 quoted lines
> This applies to origin/master. > > For better readability and understandability for newcomers it is a good idea > to not offer 2 APIs doing the same thing with on being the #define of the other. > > In the long run we may want to drop the macros guarded by > NO_THE_INDEX_COMPATIBILITY_MACROS. This converts a couple of them. > > My main reason for this patch is to try out coccinelle as well as a > discussion I had off list about maintainability of software. > > I just made these patches and wonder if now is a good time to pull through and > convert the rest as well? >
You may also want to look at unpack-trees.c : mark_new_skip_worktree(). It has a local variable named "the_index" in the argument list. You may want to rename this to avoid confusion.
Jeff