git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] Grammar fixes to "merge" and "patch-id" docs

From
Wincent Colaiuta <win@wincent.com>
Date
Mar 25, 2009, 19:03 UTC
Message-ID
<249E343F-DE3D-45B1-B733-BA33FC4F2AB8@wincent.com>
In-Reply-To
<7vocvp310v.fsf@gitster.siamese.dyndns.org>
El 25/3/2009, a las 19:33, Junio C Hamano escribió:
Show 7 quoted lines
> Wincent Colaiuta <win@wincent.com> writes:
>
>> If you tried a merge which resulted in a complex conflicts and
>> -would want to start over, you can recover with 'git-reset'.
>> +want to start over, you can recover with 'git-reset'.
>
> Reads Ok to me either way...

"tried" is in the past preterit, so the second verb, the one after the "and", should be "want" due to concordance. "would want" is not actually wrong, but it is bad form. It is a common mistake among non- native speaker to use "would" when it's not required in cases like this, probably due to confusion with the pattern "If X, I would Y" (but note that there's no "and" in that case).

(Speaking as a native English-speaker and part-time English teacher, who this very week has been teaching classes about modal verbs like "would".)

Show 14 quoted lines
>> diff --git a/Documentation/merge-strategies.txt b/Documentation/ 
>> merge-strategies.txt
>> index 1276f85..ee7f754 100644
>> --- a/Documentation/merge-strategies.txt
>> +++ b/Documentation/merge-strategies.txt
>> @@ -3,15 +3,15 @@ MERGE STRATEGIES
>>
>> resolve::
>> 	This can only resolve two heads (i.e. the current branch
>> -	and another branch you pulled from) using 3-way merge
>> +	and another branch you pulled from) using a 3-way merge
>> 	algorithm.  It tries to carefully detect criss-cross
>
> Hmph, would that be an 'a' or 'the'?

Doesn't really matter, IMO, but some kind of article is required there. If there is literally only one 3-way merge algorithm in computer science, then "the" would be best. I chose "a" because I was thinking of it as "Git's interpretation of the 3-way merge algorithm".

Show 9 quoted lines
>> recursive::
>> -	This can only resolve two heads using 3-way merge
>> -	algorithm.  When there are more than one common
>> -	ancestors that can be used for 3-way merge, it creates a
>> +	This can only resolve two heads using a 3-way merge
>> +	algorithm.  When there is more than one common
>> +	ancestor that can be used for 3-way merge, it creates a
>
> Do you need an article before the latter "3-way merge", perhaps "the"?
Probably wouldn't hurt.
Show 10 quoted lines
>> @@ -22,11 +22,11 @@ recursive::
>> 	pulling or merging one branch.
>>
>> octopus::
>> -	This resolves more than two-head case, but refuses to do
>> -	complex merge that needs manual resolution.  It is
>> +	This resolves the more than two-heads case, but refuses to do
>> +	a complex merge that needs manual resolution.  It is
>
> Perhaps "resolves cases with more than two heads" is easier to read?
Yes, I agree.

Cheers, Wincent

Previous: Junio C HamanoNext: Jeff King
Message 3 of 5 in “Grammar fixes to "merge" and "patch-id" docs”
  1. Grammar fixes to "merge" and "patch-id" docsWincent Colaiuta, Mar 25, 2009
  2. Junio C HamanoMar 25, 2009
  3. Wincent ColaiutaMar 25, 2009
  4. Jeff KingMar 26, 2009
  5. Grammar fix for "git merge" man pageWincent Colaiuta, Mar 26, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.