git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 0/11] annotating unused function parameters

From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
Date
Aug 25, 2022, 11:00 UTC
Message-ID
<220825.86edx44lzh.gmgdl@evledraar.gmail.com>
In-Reply-To
<YwCtkwjWdJVHHZV0@coredump.intra.peff.net>
On Sat, Aug 20 2022, Jeff King wrote:
Show 12 quoted lines
> On Fri, Aug 19, 2022 at 10:58:08PM +0200, Ævar Arnfjörð Bjarmason wrote:
>
>> Yes, I spoke too soon, sorry. We still need ((unused)). FWIW the below
>> on top of master and doing:
>
> Right. Using ((deprecated)) is really just a substitute for the variable
> renaming part.
>
> And I agree it works as advertised, though I think I prefer the
> variable-renaming version.
>
> One, it feels like we're abusing the deprecated attribute here. The

Definitely, but structurally it seems like a better pick. I.e. isn't the only problem with it the "deprecated" and its interaction with -Wno-deprecated.

If the exact same feature existed as a "insert-custom-warning", which would work exactly "deprecated" without the default warning "prefix" would you think this would fit perfectly?

> ...
> -Wno-deprecated-declarations to get around _actual_ deprecated warnings
> (e.g., compiling with OPENSSL_SHA1=Yes). And doing so would be cutting
> out half the protection of UNUSED() in that case.

This is mildly annoying, but I don't really think it's a practical issue. We're talking about running this without -Wno-deprecated-declarations in CI, and by default.

For unused parameters it's enough that we're catching them somewhere, or in common compilation settings, we don't need to catch them *everywhere*, do we?

IOW is anyone writing patches where they're testing with -Wno-deprecated-declarations *and* adding unused parameters *and* won't test without -Wno-deprecated-declarations before submitting them, *and* nobody else will catch it?

Show 6 quoted lines
> Likewise, one thing I like about the renaming is that it fails
> compilation regardless of -Werror. So it will be caught in any compile,
> no matter what. And I do automatically compile without DEVELOPER=1 when
> on a detached HEAD, because historical commits often trigger warnings.
> Go back far enough and OPENSSL_SHA1 was the default, which generates
> lots of warnings these days. :)

*nod*, I think this also goes the other way. It's nice to be able to use DEVOPTS=no-error to "get past" various minor issues. I consider an unused parameter as being a minor issue. E.g. when ad-hoc cherry-picking something to test on an older version it can be annoying to have to make larger changes when a DEVOPTS=no-error would do.

> And finally, I actually prefer the parentheses of:
>
>   static int register_ref(const char *refname, const struct object_id *oid,
> 			  int UNUSED(flags), void *UNUSED(cb_data))

...and now to the real reason for the follow-up. You/Junio were CC'd, but this is breaking coccinelle, see: https://lore.kernel.org/git/220825.86ilmg4mil.gmgdl@evledraar.gmail.com/

So, bikeshedding-wise I don't care to argue the point. But between odd syntax highlighting and now one analysis tool barfing on it it's a bit more than a bikeshed :)

Previous: Derrick StoleeNext: Jeff King
Message 19 of 22 in “annotating unused function parameters”
  1. 0/11 annotating unused function parametersJeff King, Aug 19, 2022
  2. 01/11 git-compat-util: add UNUSED macroJeff King, Aug 19, 2022
  3. 02/11 refs: mark unused each_ref_fn parametersJeff King, Aug 19, 2022
  4. 03/11 refs: mark unused reflog callback parametersJeff King, Aug 19, 2022
  5. 04/11 refs: mark unused virtual method parametersJeff King, Aug 19, 2022
  6. 05/11 transport: mark bundle transport_options as unusedJeff King, Aug 19, 2022
  7. 06/11 streaming: mark unused virtual method parametersJeff King, Aug 19, 2022
  8. 07/11 config: mark unused callback parametersJeff King, Aug 19, 2022
  9. 08/11 hashmap: mark unused callback parametersJeff King, Aug 19, 2022
  10. 09/11 mark unused read_tree_recursive() callback parametersJeff King, Aug 19, 2022
  11. 10/11 run-command: mark unused async callback parametersJeff King, Aug 19, 2022
  12. 11/11 is_path_owned_by_current_uid(): mark "report" parameter as unusedJeff King, Aug 19, 2022
  13. Ævar Arnfjörð BjarmasonAug 19, 2022
  14. Derrick StoleeAug 19, 2022
  15. Ævar Arnfjörð BjarmasonAug 19, 2022
  16. Jeff KingAug 20, 2022
  17. Junio C HamanoAug 20, 2022
  18. Derrick StoleeAug 22, 2022
  19. Ævar Arnfjörð BjarmasonAug 25, 2022
  20. Jeff KingAug 26, 2022
  21. Phillip WoodAug 26, 2022
  22. Junio C HamanoAug 26, 2022

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.