git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v2 3/3] t/pack-refs-tests: move the 'test_done' to callees

From
Karthik Nayak <karthik.188@gmail.com>
Date
Oct 20, 2025, 08:18 UTC
Message-ID
<20251020-refs-code-cleanup-v2-3-f5349ed0f6a5@gmail.com>
In-Reply-To
<20251020-refs-code-cleanup-v2-0-f5349ed0f6a5@gmail.com>

In ac0bad0af4 (t0601: refactor tests to be shareable, 2025-09-19), we refactored 't/t0601-reffiles-pack-refs.sh' to move all of the tests to 't/pack-refs-tests.sh', which became a common test suite which was also used by 't/t1463-refs-optimize.sh'.

This also moved the 'test_done' directive to 't/pack-refs-tests.sh'. Which inhibits additional tests from being added to either of the tests. Let's move the directive out to both the tests, so that we can add additional specific tests to them. Also the test flow logic shouldn't be part of tests which can be embedded in other test scripts.

Signed-off-by: Karthik Nayak <karthik.188@gmail.com>
---
 t/pack-refs-tests.sh          | 2 --
 t/t0601-reffiles-pack-refs.sh | 2 ++
 t/t1463-refs-optimize.sh      | 2 ++
 3 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/t/pack-refs-tests.sh b/t/pack-refs-tests.sh
index 095823d915..81086c3690 100644
--- a/t/pack-refs-tests.sh
+++ b/t/pack-refs-tests.sh
@@ -459,5 +459,3 @@ test_expect_success 'pack-refs does not store invalid peeled tag value' '
 		test_grep ! "^\^" .git/packed-refs
 	)
 '
-
-test_done
diff --git a/t/t0601-reffiles-pack-refs.sh b/t/t0601-reffiles-pack-refs.sh
index 12cf5d1dcb..3c706978ef 100755
--- a/t/t0601-reffiles-pack-refs.sh
+++ b/t/t0601-reffiles-pack-refs.sh
@@ -18,3 +18,5 @@ export GIT_TEST_DEFAULT_REF_FORMAT
 . ./test-lib.sh
 
 . "$TEST_DIRECTORY"/pack-refs-tests.sh
+
+test_done
diff --git a/t/t1463-refs-optimize.sh b/t/t1463-refs-optimize.sh
index c11c905d79..9afe3c1ed7 100755
--- a/t/t1463-refs-optimize.sh
+++ b/t/t1463-refs-optimize.sh
@@ -15,3 +15,5 @@ export GIT_TEST_DEFAULT_REF_FORMAT
 
 pack_refs='refs optimize'
 . "$TEST_DIRECTORY"/pack-refs-tests.sh
+
+test_done
-- 
2.51.0
Previous: Karthik NayakNext: Patrick Steinhardt
Message 4 of 6 in “refs: cleanup code around optimizations”
  1. 0/3 refs: cleanup code around optimizationsKarthik Nayak, Oct 20, 2025
  2. 1/3 refs: move to using the '.optimize' functionsKarthik Nayak, Oct 20, 2025
  3. 2/3 refs: rename 'pack_refs_opts' to 'refs_optimize_opts'Karthik Nayak, Oct 20, 2025
  4. 3/3 t/pack-refs-tests: move the 'test_done' to calleesKarthik Nayak, Oct 20, 2025
  5. Patrick SteinhardtOct 21, 2025
  6. Karthik NayakOct 22, 2025

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.