[PATCH 0/4] refs: cleanup code around optimizations
- From
Karthik Nayak <karthik.188@gmail.com>
- Date
- Oct 15, 2025, 21:25 UTC
- Message-ID
- <20251015-refs-code-cleanup-v1-0-550fdd8a3b41@gmail.com>
This is extracted from a recent series I sent [1], which I've since dropped to follow up with a different approach. I think these patches hold value individually.
They mostly cleanup code around 'git refs optimize' which was added recently in db0babf9b2 (Merge branch 'ms/refs-optimize', 2025-10-02). The code in the refs subsystem contains both 'pack-refs' and 'optimize' functions, which are one and the same.
This series unifies this to only retain the 'optimize' functions and naming, since it backend generic.
This is based on top of master 143f58ef75 (Sync with Git 2.51.1, 2025-10-15) with 'ps/ref-peeled-tags' merged in.
[1]: 20251010-562-add-option-to-check-if-reference-backend-needs-repacking-v1-0-c7962be584fa@gmail.com
Signed-off-by: Karthik Nayak <karthik.188@gmail.com> --- pack-refs.c | 8 ++++---- refs.c | 8 +------- refs.h | 24 +++++++++--------------- refs/debug.c | 8 ++++---- refs/files-backend.c | 22 ++++++---------------- refs/packed-backend.c | 6 +++--- refs/refs-internal.h | 5 +---- refs/reftable-backend.c | 15 ++++----------- t/pack-refs-tests.sh | 2 -- t/t0601-reffiles-pack-refs.sh | 2 ++ t/t1463-refs-optimize.sh | 2 ++ 11 files changed, 36 insertions(+), 66 deletions(-)
Karthik Nayak (4):
refs: move to using the '.optimize' functions
refs: cleanup code around optimization
refs: rename 'pack_refs_opts' to 'refs_optimize_opts'
t/pack-refs-tests: move the 'test_done' to calleesbase-commit: 854a80fd48848f942c4a566c9880dc5f089887af change-id: 20251015-refs-code-cleanup-871a7ce7c8dd
Thanks - Karthik