jk/zlib-inflate-fixes, was Re: What's cooking in git.git (Mar 2025, #07; Wed, 26)
- From
Jeff King <peff@peff.net>
- Date
- Apr 4, 2025, 09:02 UTC
- Message-ID
- <20250404090253.GB772404@coredump.intra.peff.net>
- In-Reply-To
- <xmqqiknwhsdz.fsf@gitster.g>
On Wed, Mar 26, 2025 at 05:46:00AM -0700, Junio C Hamano wrote:
Show 17 quoted lines
> * jk/zlib-inflate-fixes (2025-02-25) 10 commits > - unpack_loose_rest(): rewrite return handling for clarity > - unpack_loose_rest(): simplify error handling > - unpack_loose_rest(): never clean up zstream > - unpack_loose_rest(): avoid numeric comparison of zlib status > - unpack_loose_header(): avoid numeric comparison of zlib status > - git_inflate(): skip zlib_post_call() sanity check on Z_NEED_DICT > - unpack_loose_header(): fix infinite loop on broken zlib input > - unpack_loose_header(): report headers without NUL as "bad" > - unpack_loose_header(): simplify next_out assignment > - loose_object_info(): BUG() on inflating content with unknown type > > Fix our use of zlib corner cases. > > Still being discussed. > cf. <20250304065501.GB1283901@coredump.intra.peff.net> > source: <20250225062518.GA1293854@coredump.intra.peff.net>
I don't think there's any more discussion happening here. IMHO it is ready for 'next'. The message you have in the cf. is about further possible cleanups for cat-file, which I think are out of scope.
I think you and I also discussed getting rid of support for these non-standard headers entirely, which would obsolete some of this work. I think that's worth doing (and I started on some patches towards it), but it would be a bigger change that breaks backwards compatibility. So I think we'd want these fixes in the meantime.
-Peff