Re: [RFC PATCH] object-name: add @{upstreamhead} shorthand
- From
Jeff King <peff@peff.net>
- Date
- Oct 28, 2024, 05:33 UTC
- Message-ID
- <20241028053315.GA2827304@coredump.intra.peff.net>
- In-Reply-To
- <D56XI8GBH2GF.3MP02MGQGP5M@ferdinandy.com>
On Sun, Oct 27, 2024 at 11:07:07PM +0100, Bence Ferdinandy wrote:
Show 10 quoted lines
> >> I'd probably call the flag something like "--current", "--current-only" rather > >> than "--is-head" though. "--is-head" sounds as if it would filter --list but > >> not necessarily end up with a single entry. > > > > Yeah, I think --current would be fine. > > I was looking through git branch and there is a --show-current option. I was > wondering, would it not be better to teach --show-current to also obey > --format? It would avoid having a "--current" that only works with "--list" > besides having a "--show-current".
Yeah, that's perfect. I had almost suggested "--list-head" originally, but I didn't want to introduce yet another major-mode to git-branch. But if we already have it, that's not a problem. :)
And the patch should be quite short, I'd think.
-Peff