[PATCH 0/5] make room for "special ref"
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Dec 15, 2023, 20:32 UTC
- Message-ID
- <20231215203245.3622299-1-gitster@pobox.com>
Patrick's reftable work is progressing nicely and wants to establish "special ref" as a phrase with some defined meaning that is somewhat different from a mere "pseudo ref".
A pseudo ref is merely a normal ref with a funny naming convention, i.e., being outside the refs/ hierarchy and has names with all uppercase letters (or an underscore). But there truly are refs that are more than that. For example, FETCH_HEAD currently stores not just a single object name, but can and is used to store multiple object names, each with annotations to record where they came from. There indeed may be a need to introduce a new term to refer to such "special refs".
Existing documentation, however, uses "special ref" to refer to pseudo refs without any "special" property, like FETCH_HEAD does.
This series merely corrects such existing uses of the word, to make room for Patrick's series to introduce (and formally define in the glossary) "special refs".
Junio C Hamano (5): git.txt: HEAD is not that special git-bisect.txt: BISECT_HEAD is not that special refs.h: HEAD is not that special docs: AUTO_MERGE is not that special docs: MERGE_AUTOSTASH is not that special
Documentation/git-bisect.txt | 2 +- Documentation/git-diff.txt | 2 +- Documentation/git-merge.txt | 2 +- Documentation/git.txt | 7 ++++--- Documentation/merge-options.txt | 2 +- Documentation/user-manual.txt | 2 +- refs.h | 2 +- 7 files changed, 10 insertions(+), 9 deletions(-)
-- 2.43.0-76-g1a87c842ec