Re: [PATCH] grep: use OPT_INTEGER_F for --max-depth
- From
Jeff King <peff@peff.net>
- Date
- Sep 5, 2023, 07:21 UTC
- Message-ID
- <20230905072122.GG199565@coredump.intra.peff.net>
- In-Reply-To
- <4d2eb736-4f34-18f8-2eb7-20e7f7b8c2f8@web.de>
On Sat, Sep 02, 2023 at 08:54:54PM +0200, René Scharfe wrote:
Show 8 quoted lines
> a91f453f64 (grep: Add --max-depth option., 2009-07-22) added the option
> --max-depth, defining it using a positional struct option initializer of
> type OPTION_INTEGER. It also sets defval to 1 for some reason, but that
> value would only be used if the flag PARSE_OPT_OPTARG was given.
>
> Use the macro OPT_INTEGER_F instead to standardize the definition and
> specify only the necessary values. This also normalizes argh to N_("n")
> as a side-effect, which is OK.This looks correct to me (and an improvement in readability). In general, I wonder how many of the results from:
git grep '{ OPTION'could be converted to use the macros and end up more readable. There are a number of OPTARG ones, which I guess can't use macros. Looks like there are a handful of others (mostly for OPT_HIDDEN).
-Peff