Re: [PATCH v2] switch: fix errors and comments related to -c and -C
- From
Taylor Blau <me@ttaylorr.com>
- Date
- Apr 30, 2020, 16:21 UTC
- Message-ID
- <20200430162151.GB30682@syl.local>
- In-Reply-To
- <75c9cf6ce95e753f50ce9b8b86b2c3ded5d8d38d.1588247662.git.liu.denton@gmail.com>
On Thu, Apr 30, 2020 at 07:54:57AM -0400, Denton Liu wrote:
Show 19 quoted lines
> In d787d311db (checkout: split part of it to new command 'switch', > 2019-03-29), the `git switch` command was created by extracting the > common functionality of cmd_checkout() in checkout_main(). However, in > b7b5fce270 (switch: better names for -b and -B, 2019-03-29), the branch > creation and force creation options for 'switch' were changed to -c and > -C, respectively. As a result of this, error messages and comments that > previously referred to `-b` and `-B` became invalid for `git switch`. > > For error messages that refer to `-b` and `-B`, use a format string > instead so that `-c` and `-C` can be printed when `git switch` is > invoked. > > Reported-by: Robert Simpson > Signed-off-by: Denton Liu <liu.denton@gmail.com> > --- > > Notes: > Robert, is the email listed above correct? If not, please let me know > which email to use. (I hope that this reaches you somehow.)
Nicely done. This revision looks great to me, thanks.
Reviewed-by: Taylor Blau <me@ttaylorr.com>
Thanks, Taylor