Re: What's cooking in git.git (Apr 2020, #03; Tue, 28)
- From
Taylor Blau <me@ttaylorr.com>
- Date
- Apr 29, 2020, 15:57 UTC
- Message-ID
- <20200429155701.GA83442@syl.local>
- In-Reply-To
- <xmqqimhjyy9c.fsf@gitster.c.googlers.com>
On Tue, Apr 28, 2020 at 04:41:03PM -0700, Junio C Hamano wrote:
Show 6 quoted lines
> * tb/diff-tree-with-notes (2020-04-20) 1 commit > (merged to 'next' on 2020-04-22 at c06610c916) > + diff-tree.c: load notes machinery when required > > "git diff-tree --pretty --notes" used to hit an assertion failure, > as it forgot to initialize the notes subsystem.
Thanks, I'm happy to see this merged.
Show 9 quoted lines
> * tb/reset-shallow (2020-04-24) 2 commits
> (merged to 'next' on 2020-04-28 at 9510639ae8)
> + shallow.c: use '{commit,rollback}_shallow_file'
> + t5537: use test_write_lines and indented heredocs for readability
>
> Fix in-core inconsistency after fetching into a shallow repository
> that broke the code to write out commit-graph.
>
> Will merge to 'master'.Likewise. I promised you and Jonathan Nieder a follow-up series in [1] to move some of the declarations in commit.h to a new shallow.h, and to introduce a 'struct shallow_lock'. I have those patches locally, but I'll send them shortly.
Show 12 quoted lines
> * tb/commit-graph-fd-exhaustion-fix (2020-04-24) 4 commits > (merged to 'next' on 2020-04-28 at 6d5fd6bc49) > + commit-graph: close descriptors after mmap > + commit-graph.c: gracefully handle file descriptor exhaustion > + t/test-lib.sh: make ULIMIT_FILE_DESCRIPTORS available to tests > + commit-graph.c: don't use discarded graph_name in error > (this branch uses tb/commit-graph-split-strategy.) > > The commit-graph code exhausted file descriptors easily when it > does not have to. > > Will merge to 'master'.
I'm _very_ glad to see this one merged ;).
Show 13 quoted lines
> * tb/commit-graph-perm-bits (2020-04-27) 6 commits > - commit-graph.c: make 'commit-graph-chain's read-only > - commit-graph.c: ensure graph layers respect core.sharedRepository > - SQUASH??? force known umask if you are going to check the resulting mode bits > - commit-graph.c: write non-split graphs as read-only > - lockfile.c: introduce 'hold_lock_file_for_update_mode' > - tempfile.c: introduce 'create_tempfile_mode' > > Some of the files commit-graph subsystem keeps on disk did not > correctly honor the core.sharedRepository settings and some were > left read-write. > > Expecting a reroll.
Reroll coming shortly, sorry about the trouble here.
Show 14 quoted lines
> * tb/commit-graph-split-strategy (2020-04-15) 7 commits > + commit-graph.c: introduce '--[no-]check-oids' > + commit-graph.h: replace 'commit_hex' with 'commits' > + oidset: introduce 'oidset_size' > + builtin/commit-graph.c: introduce split strategy 'replace' > + builtin/commit-graph.c: introduce split strategy 'no-merge' > + builtin/commit-graph.c: support for '--split[=<strategy>]' > + t/helper/test-read-graph.c: support commit-graph chains > (this branch is used by tb/commit-graph-fd-exhaustion-fix.) > > "git commit-graph write" learned different ways to write out split > files. > > Will merge to 'master'.
I know this series has been kind of a slog, but I would like to hold off on the last patch to introduce '--no-check-oids' here. The other patches all seem to be set (and were mostly already reviewed when I sent this series for the first time), but the last patch still is under discussion [2].
My thought is that we could either replace that patch with one to silently ignore non-commits always, or keep it and rename it to '--[no-]verify-oids' with some minor documentation changes.
In either case, the rest of the series is ready to merge, and other topics depend on it, so I figure that we can merge the first 6 patches and hold off on the last one for now.
Sound good?
Thanks, Taylor
[1]: https://lore.kernel.org/git/20200424171301.GB61470@syl.local/ [2]: https://lore.kernel.org/git/20200424105957.GB5925@szeder.dev/