git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] merge: use skip_prefix to parse config key

From
Jeff King <peff@peff.net>
Date
Apr 10, 2020, 15:58 UTC
Message-ID
<20200410155827.GA71011@coredump.intra.peff.net>
In-Reply-To
<20200410151032.23198-1-martin.agren@gmail.com>
On Fri, Apr 10, 2020 at 05:10:32PM +0200, Martin Ågren wrote:
> Instead of using `starts_with()`, the magic number 7, `strlen()` and a
> fair number of additions to verify the three parts of the config key
> "branch.<branch>.mergeoptions", use `skip_prefix()` to jump through them
> more explicitly.
The conversion looks correct to me and is certainly an improvement.
Show 5 quoted lines
> We need to introduce a new variable for this (we certainly can't modify
> `k` just because we see "branch."!). With `skip_prefix()` we often use
> quite bland names like `p` or `str`. Let's do the same. If and when this
> function needs to do more prefix-skipping, we'll have a generic variable
> ready for this.

I was about to comment on this in the patch, but your explanation preempted me. :) The logic here makes sense.

Show 18 quoted lines
> diff --git a/builtin/merge.c b/builtin/merge.c
> index d127d2225f..bde5f14f05 100644
> --- a/builtin/merge.c
> +++ b/builtin/merge.c
> @@ -597,10 +597,10 @@ static void parse_branch_merge_options(char *bmo)
>  static int git_merge_config(const char *k, const char *v, void *cb)
>  {
>  	int status;
> +	const char *str;
>  
> -	if (branch && starts_with(k, "branch.") &&
> -		starts_with(k + 7, branch) &&
> -		!strcmp(k + 7 + strlen(branch), ".mergeoptions")) {
> +	if (branch && skip_prefix(k, "branch.", &str) &&
> +	    skip_prefix(str, branch, &str) && !strcmp(str, ".mergeoptions")) {
>  		free(branch_mergeoptions);
>  		branch_mergeoptions = xstrdup(v);
>  		return 0;

In general, parsing subsections accurately involves looking from both the start and the end of the string, pulling out the section and key and leaving the rest in the middle. But I think we can get away with this left-to-right parsing because we're only interested in matching a _specific_ subsection name, and a specific key. So there are no cases it will handle incorrectly.

The more general form would be:
  const char *subsection, *key;
  int subsection_len;
  if (!parse_config_key("branch", &subsection, &subsection_len, &key) &&
      subsection_len == strlen(branch) && !strncmp(subsection, branch) &&
      !strcmp(key, "mergeoptions"))
         ...

but that's a bit more awkward (it would be less so if we had a helper function for comparing a NUL-terminated string against a ptr/len pair).

-Peff
Previous: Martin ÅgrenNext: Junio C Hamano
Message 2 of 6 in “merge: use skip_prefix to parse config key”
  1. merge: use skip_prefix to parse config keyMartin Ågren, Apr 10, 2020
  2. Jeff KingApr 10, 2020
  3. Junio C HamanoApr 10, 2020
  4. Jeff KingApr 10, 2020
  5. Junio C HamanoApr 10, 2020
  6. merge: use skip_prefix to parse config keyMartin Ågren, Apr 11, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.