[PATCH v2 0/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
- From
Shourya Shukla <shouryashukla.oo@gmail.com>
- Date
- Mar 18, 2020, 14:20 UTC
- Message-ID
- <20200318142024.16681-1-shouryashukla.oo@gmail.com>
- In-Reply-To
- <20200318095842.27679-1-shouryashukla.oo@gmail.com>
Subcommands in 'submodule--helper.c' which give a callback to other functions have structures and macros named in the format: 'subcommand_cb' and 'SUBCOMMAND_CB_INIT' respectively.
The subcommand 'foreach' did not follow this convention and therefore had the naming of the form: 'struct foreach_cb' and 'CB_FOREACH_INIT'. Rename these to: 'struct foreach_cb' and 'FOREACH_CB_INIT' respectively.
Changes in v2: Reworded the commit message. The last statement was wrong. Changed it from: "Rename the aforementioned structures and macros: 'struct foreach_cb' to 'struct cb_foreach' and 'CB_FOREACH_INIT' to 'FOREACH_CB_INIT'." ;to: "Rename the aforementioned structures and macros: 'struct cb_foreach' to 'struct foreach_cb' and 'CB_FOREACH_INIT' to 'FOREACH_CB_INIT'."
Shourya Shukla (1): submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
builtin/submodule--helper.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)
-- 2.20.1