Re: [PATCH RFC 09/20] ref-filter: make expand_data global
- From
Jeff King <peff@peff.net>
- Date
- Feb 28, 2019, 21:30 UTC
- Message-ID
- <20190228213015.GI12723@sigill.intra.peff.net>
- In-Reply-To
- <0102016915f49a58-dc12f07d-00e6-42be-812b-3072d33910d3-000000@eu-west-1.amazonses.com>
On Fri, Feb 22, 2019 at 04:05:45PM +0000, Olga Telezhnaya wrote:
> Put struct expand_data into global scope to reuse it > in cat-file.
So this is the payoff for moving all those things out of expand_data. Instead of just replicating the bits it needs in ref-filter, we're making it globally available.
At this point in the series, I'm still unconvinced that this is the right direction, but I haven't read all the way to the end yet.
This probably needs a better name. In the context of cat-file, expand_data is the data struct we feed to strbuf_expand(). But in the global namespace of all of Git, it needs a more descriptive name.
This likely goes away (or becomes private to ref-filter.c) in the end, but it probably needs a different name there, too. We're not calling strbuf_expand() from there.
-Peff