Re: [RFC PATCH 1/5] ref-filter: add objectsize:disk option
- From
Jeff King <peff@peff.net>
- Date
- Nov 12, 2018, 13:05 UTC
- Message-ID
- <20181112130525.GK3956@sigill.intra.peff.net>
- In-Reply-To
- <xmqqr2fq3n1j.fsf@gitster-ct.c.googlers.com>
On Mon, Nov 12, 2018 at 02:03:20PM +0900, Junio C Hamano wrote:
Show 12 quoted lines
> > + } else if (!strcmp(name, "objectsize")) {
> > v->value = oi->size;
> > v->s = xstrfmt("%lu", oi->size);
>
> This is not a suggestion but is a genuine question, but I wonder if
> two years down the road somebody who meets this API for the first
> time find the asymmetry between "objectsize" and "objectsize:disk" a
> tad strange and suggest the former to have "objectsize:real" or some
> synonym. Or we can consider "objectsize" the primary thing (hence
> needing no colon-plus-modifier to clarify what kind of size we are
> asking) and leave these two deliberatly asymmetric. I am leaning
> towards the latter myself.I think to some degree that ship has already sailed (and is my fault!).
The ulterior motive here is to eventually unify the cat-file formatter with the ref-filter formatter. So for that we'll have to support %(objectsize) anyway.
That still leaves the option of having %(objectsize:real) later and marking a bare %(objectsize) as a deprecated synonym. But I don't think there's any advantage to trying to deal with it at this stage.
-Peff