Re: [PATCH v2 1/1] setup: recognise extensions.objectFormat
- From
brian m. carlson <sandals@crustytoothpaste.net>
- Date
- Jan 28, 2018, 15:40 UTC
- Message-ID
- <20180128154022.GG431130@genre.crustytoothpaste.net>
- In-Reply-To
- <e430ad029facdd6209927d352f0e7545cdd0e435.1517098675.git.patryk.obara@gmail.com>
On Sun, Jan 28, 2018 at 01:36:17AM +0100, Patryk Obara wrote:
> This extension selects which hashing algorithm from vtable should be > used for reading and writing objects in the object store. At the moment > supports only single value (sha-1).
I think you want an "it" here: "At the moment *it* supports".
Show 16 quoted lines
> In case value of objectFormat is an unknown hashing algorithm, Git > command will fail with following message: > > fatal: unknown repository extensions found: > objectformat = <value> > > To indicate, that this specific objectFormat value is not recognised. > > The objectFormat extension is not allowed in repository marked as > version 0 to prevent any possibility of accidentally writing a NewHash > object in the sha-1 object store. This extension behaviour is different > than preciousObjects extension (which is allowed in repo version 0). > > Add tests and documentation note about new extension. > > Signed-off-by: Patryk Obara <patryk.obara@gmail.com>
Other than that, the patch looks good to me. I like that we reject invalid values immediately. Adding documentation is good, too.
-- brian m. carlson / brian with sandals: Houston, Texas, US https://www.crustytoothpaste.net/~bmc | My opinion only OpenPGP: https://keybase.io/bk2204