[PATCH 0/4] Move unquote_path from git-add--interactive.perl to Git.pm
- From
- Phillip Wood <phillip.wood@talktalk.net>
- Date
- Jun 30, 2017, 09:49 UTC
- Message-ID
- <20170630094912.8653-1-phillip.wood@talktalk.net>
- In-Reply-To
- <20170622102622.26147-1-phillip.wood@talktalk.net>
From: Phillip Wood <phillip.wood@dunelm.org.uk>
Thanks for the review Junio, I've amended the patches as you suggested.
The first patch now removes unquote_path() from add -i as well as adding it to Git.pm. I've fixed the naming issues (the version I sent previously was copied from another script rather than directly from add -i, I thought it was identical but must have changed it slightly when I copied the original and then forgotten I'd made some changes) I also expanded the documentation very slightly to mention parsing diff -u as I think using -z isn't possible for that.
The error message in the third patch now starts with a lowercase letter.
Best Wishes
Phillip
Phillip Wood (4): add -i move unquote_path() to Git.pm Git::unquote_path() Handle '\a' Git::unquote_path() throw an exception on bad path Add tests for Git::unquote_path()
git-add--interactive.perl | 43 +------------------------------------ perl/Git.pm | 54 ++++++++++++++++++++++++++++++++++++++++++++++- t/t9700/test.pl | 7 ++++++ 3 files changed, 61 insertions(+), 43 deletions(-)
-- 2.13.1