Re: [PATCH] interpret-trailers: obey scissors lines
- From
Brian Malehorn <bmalehorn@gmail.com>
- Date
- May 14, 2017, 08:33 UTC
- Message-ID
- <20170514083349.24979-1-bmalehorn@gmail.com>
- In-Reply-To
- <20170514035652.rn5npxxflku6s5k4@sigill.intra.peff.net>
> One, we'd usually use "\EOF" here unless you > really do want to interpolate inside the here document.
Fixed, and I learned something new.
> And two, we usually indent the contents to the same level as the outer > cat/EOF pair
Fixed.
I was indenting the same as the other tests in that file. But if the way you described is the preferred way, then sure.
> Another way to think of it is still as a truncation. Our strip_suffix() > helper behaves quite similarly to this (not actually writing into the > buffer, but returning the new length). Perhaps something like > "wt_status_strip_scissors" would work.
I agree the name was pretty awkward. I was trying to avoid using the word "truncate" or "strip", since it doesn't make any change to the buffer. But if strip_suffix() is already around it shouldn't be to surprising.
I've now renamed it to "wt_status_strip_scissors".