git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v3 01/20] Define new hash-size constants for allocating memory

From
brian m. carlson <sandals@crustytoothpaste.net>
Date
Mar 31, 2017, 01:39 UTC
Message-ID
<20170331014001.953484-2-sandals@crustytoothpaste.net>
In-Reply-To
<20170331014001.953484-1-sandals@crustytoothpaste.net>

Since we will want to transition to a new hash at some point in the future, and that hash may be larger in size than 160 bits, introduce two constants that can be used for allocating a sufficient amount of memory. They can be increased to reflect the largest supported hash size.

Signed-off-by: brian m. carlson <sandals@crustytoothpaste.net>
---
 cache.h | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/cache.h b/cache.h
index db4120c233..02b6c753a3 100644
--- a/cache.h
+++ b/cache.h
@@ -66,8 +66,12 @@ unsigned long git_deflate_bound(git_zstream *, unsigned long);
 #define GIT_SHA1_RAWSZ 20
 #define GIT_SHA1_HEXSZ (2 * GIT_SHA1_RAWSZ)
 
+/* The length in byte and in hex digits of the largest possible hash value. */
+#define GIT_MAX_RAWSZ GIT_SHA1_RAWSZ
+#define GIT_MAX_HEXSZ GIT_SHA1_HEXSZ
+
 struct object_id {
-	unsigned char hash[GIT_SHA1_RAWSZ];
+	unsigned char hash[GIT_MAX_RAWSZ];
 };
 
 #if defined(DT_UNKNOWN) && !defined(NO_D_TYPE_IN_DIRENT)
Previous: brian m. carlsonNext: brian m. carlson
Message 18 of 24 in “object_id part 7”
  1. 00/20 object_id part 7brian m. carlson, Mar 31, 2017
  2. 04/20 builtin/diff: convert to struct object_idbrian m. carlson, Mar 31, 2017
  3. 09/20 test-sha1-array: convert most code to struct object_idbrian m. carlson, Mar 31, 2017
  4. 13/20 builtin/pull: convert to struct object_idbrian m. carlson, Mar 31, 2017
  5. 15/20 Make sha1_array_append take a struct object_id *brian m. carlson, Mar 31, 2017
  6. 12/20 submodule: convert check_for_new_submodule_commits to object_idbrian m. carlson, Mar 31, 2017
  7. 16/20 Convert remaining callers of sha1_array_lookup to object_idbrian m. carlson, Mar 31, 2017
  8. 19/20 Rename sha1_array to oid_arraybrian m. carlson, Mar 31, 2017
  9. 20/20 Documentation: update and rename api-sha1-array.txtbrian m. carlson, Mar 31, 2017
  10. 14/20 sha1-array: convert internal storage for struct sha1_array to object_idbrian m. carlson, Mar 31, 2017
  11. Junio C HamanoMar 31, 2017
  12. 18/20 Convert sha1_array_for_each_unique and for_each_abbrev to object_idbrian m. carlson, Mar 31, 2017
  13. 07/20 fsck: convert init_skiplist to struct object_idbrian m. carlson, Mar 31, 2017
  14. 17/20 Convert sha1_array_lookup to take struct object_idbrian m. carlson, Mar 31, 2017
  15. 11/20 sha1_name: convert disambiguate_hint_fn to take object_idbrian m. carlson, Mar 31, 2017
  16. 08/20 parse-options-cb: convert sha1_array_append caller to struct object_idbrian m. carlson, Mar 31, 2017
  17. 10/20 sha1_name: convert struct disambiguate_state to object_idbrian m. carlson, Mar 31, 2017
  18. 01/20 Define new hash-size constants for allocating memorybrian m. carlson, Mar 31, 2017
  19. 03/20 Convert GIT_SHA1_RAWSZ used for allocation to GIT_MAX_RAWSZbrian m. carlson, Mar 31, 2017
  20. 05/20 builtin/pull: convert portions to struct object_idbrian m. carlson, Mar 31, 2017
  21. 06/20 builtin/receive-pack: convert portions to struct object_idbrian m. carlson, Mar 31, 2017
  22. René ScharfeJul 15, 2017
  23. 02/20 Convert GIT_SHA1_HEXSZ used for allocation to GIT_MAX_HEXSZbrian m. carlson, Mar 31, 2017
  24. Junio C HamanoMar 31, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.