Re: [PATCH 6/6] rm: add absorb a submodules git dir before deletion
- From
brian m. carlson <sandals@crustytoothpaste.net>
- Date
- Dec 13, 2016, 03:28 UTC
- Message-ID
- <20161213032848.4ps42jinix6fdgdc@genre.crustytoothpaste.net>
- In-Reply-To
- <20161213014055.14268-7-sbeller@google.com>
On Mon, Dec 12, 2016 at 05:40:55PM -0800, Stefan Beller wrote:
Show 8 quoted lines
> When deleting a submodule we need to keep the actual git directory around, > such that we do not lose local changes in there and at a later checkout > of the submodule we don't need to clone it again. > > Implement `depopulate_submodule`, that migrates the git directory before > deletion of a submodule and afterwards the equivalent of "rm -rf", which > is already found in entry.c, so expose that and for clarity add a suffix > "_or_dir" to it.
I think you might have meant "_or_die" here.
Other than that, I didn't see anything that stuck out to me in this series as obviously wrong or broken, but this isn't an area of the code I'm super familiar with.
-- brian m. carlson / brian with sandals: Houston, Texas, US +1 832 623 2791 | https://www.crustytoothpaste.net/~bmc | My opinion only OpenPGP: https://keybase.io/bk2204