Re: [PATCH 4/7] run-command: add pipe_command helper
- From
Jeff King <peff@peff.net>
- Date
- Jun 17, 2016, 23:28 UTC
- Message-ID
- <20160617232857.GA26564@sigill.intra.peff.net>
- In-Reply-To
- <CAPig+cR-Z+dpKN0dG_BG7JWRBZeo4Xtpa1HQAU1Tt3WRunsrXg@mail.gmail.com>
On Fri, Jun 17, 2016 at 04:03:18PM -0400, Eric Sunshine wrote:
Show 15 quoted lines
> > diff --git a/run-command.h b/run-command.h > > @@ -79,17 +79,34 @@ int run_command_v_opt(const char **argv, int opt); > > /** > > - * Execute the given command, capturing its stdout in the given strbuf. > > + * Execute the given command, sending "in" to its stdin, and capturing its > > + * stdout and stderr in the "out" and "err" strbufs. Any of the three may > > + * be NULL to skip processing. > > + * > > * Returns -1 if starting the command fails or reading fails, and otherwise > > - * returns the exit code of the command. The output collected in the > > - * buffer is kept even if the command returns a non-zero exit. The hint field > > - * gives a starting size for the strbuf allocation. > > + * returns the exit code of the command. Any output collected in the > > Did you mean s/returns/Returns/ ?
I don't think so. This is a continuatino of "...and otherwise" from the context line above.
Show 10 quoted lines
> > + * buffers is kept even if the command returns a non-zero exit. The hint fields > > + * gives starting sizes for the strbuf allocations. > > * > > * The fields of "cmd" should be set up as they would for a normal run_command > > - * invocation. But note that there is no need to set cmd->out; the function > > - * sets it up for the caller. > > + * invocation. But note that there is no need to set the in, out, or err > > + * fields; capture_command handles that automatically. > > s/capture_command/pipe_command/
Whoops, yes.
-Peff