git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 2/3] remote-curl: use error instead of fprintf(stderr)

From
Jeff King <peff@peff.net>
Date
Jul 9, 2014, 21:47 UTC
Message-ID
<20140709214705.GB26999@sigill.intra.peff.net>
In-Reply-To
<20140709212043.GC25854@sigill.intra.peff.net>

We usually prefix our error messages with "error: ", but many error messages from remote-curl are simply printed with fprintf. This can make the output a little harder to read (especially because such message may be intermingled with errors from the parent git process).

There is no reason to avoid error(), as we are already calling it many places (in addition to libgit.a functions which use it).

While we're adjusting the messages, we can also drop the capitalization which makes them unlike other git error messages.

Signed-off-by: Jeff King <peff@peff.net>
---
I suspect there may be some more improvements we can make (e.g., the
"fetch failed" below seems like it might be redundant with what "git
fetch" will print). But hunting them is a lot of work for little gain;
I'd rather wait to see them in practice and fix them on a case by case
basis.
 remote-curl.c | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/remote-curl.c b/remote-curl.c
index 0454ffc..a619b64 100644
--- a/remote-curl.c
+++ b/remote-curl.c
@@ -399,7 +399,7 @@ static curlioerr rpc_ioctl(CURL *handle, int cmd, void *clientp)
 			rpc->pos = 0;
 			return CURLIOE_OK;
 		}
-		fprintf(stderr, "Unable to rewind rpc post data - try increasing http.postBuffer\n");
+		error("unable to rewind rpc post data - try increasing http.postBuffer");
 		return CURLIOE_FAILRESTART;
 
 	default:
@@ -709,7 +709,7 @@ static int fetch_dumb(int nr_heads, struct ref **to_fetch)
 		free(targets[i]);
 	free(targets);
 
-	return ret ? error("Fetch failed.") : 0;
+	return ret ? error("fetch failed.") : 0;
 }
 
 static int fetch_git(struct discovery *heads,
@@ -949,7 +949,7 @@ int main(int argc, const char **argv)
 	git_extract_argv0_path(argv[0]);
 	setup_git_directory_gently(&nongit);
 	if (argc < 2) {
-		fprintf(stderr, "Remote needed\n");
+		error("remote needed");
 		return 1;
 	}
 
@@ -970,7 +970,7 @@ int main(int argc, const char **argv)
 	do {
 		if (strbuf_getline(&buf, stdin, '\n') == EOF) {
 			if (ferror(stdin))
-				fprintf(stderr, "Error reading command stream\n");
+				error("error reading command stream");
 			return 1;
 		}
 		if (buf.len == 0)
@@ -1014,7 +1014,7 @@ int main(int argc, const char **argv)
 			printf("\n");
 			fflush(stdout);
 		} else {
-			fprintf(stderr, "Unknown command '%s'\n", buf.buf);
+			error("unknown command '%s'", buf.buf);
 			return 1;
 		}
 		strbuf_reset(&buf);
-- 
2.0.0.566.gfe3e6b2
Previous: Jeff KingNext: Jeff King
Message 7 of 8 in “"Unexpected end of command stream" message looks irrelevant when I try to pull a non-existing branch”
  1. DmitryJul 9, 2014
  2. Jeff KingJul 9, 2014
  3. remote-curl: do not complain on EOF from parent gitJeff King, Jul 9, 2014
  4. Keller, Jacob EJul 9, 2014
  5. Jeff KingJul 9, 2014
  6. 1/3 remote-curl: do not complain on EOF from parent gitJeff King, Jul 9, 2014
  7. 2/3 remote-curl: use error instead of fprintf(stderr)Jeff King, Jul 9, 2014
  8. 3/3 remote-curl: mark helper-protocol errors more clearlyJeff King, Jul 9, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.