git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v6 4/7] pull: add --merge option

From
brian m. carlson <sandals@crustytoothpaste.net>
Date
May 2, 2014, 01:37 UTC
Message-ID
<20140502013753.GE75770@vauxhall.crustytoothpaste.net>
In-Reply-To
<1398988808-29678-5-git-send-email-felipe.contreras@gmail.com>
On Thu, May 01, 2014 at 07:00:05PM -0500, Felipe Contreras wrote:
Show 24 quoted lines
> Also, deprecate --no-rebase since there's no need for it any more.
> 
> Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com>
> ---
>  Documentation/git-pull.txt |  8 ++++++--
>  git-pull.sh                | 10 +++++++++-
>  2 files changed, 15 insertions(+), 3 deletions(-)
> 
> diff --git a/Documentation/git-pull.txt b/Documentation/git-pull.txt
> index 9a91b9f..767bca3 100644
> --- a/Documentation/git-pull.txt
> +++ b/Documentation/git-pull.txt
> @@ -127,8 +127,12 @@ It rewrites history, which does not bode well when you
>  published that history already.  Do *not* use this option
>  unless you have read linkgit:git-rebase[1] carefully.
>  
> ---no-rebase::
> -	Override earlier --rebase.
> +-m::
> +--merge::
> +	Force a merge.
> ++
> +See `pull.mode`, `branch.<name>.pullmode` in linkgit:git-config[1] if you want
> +to make `git pull` always use `--merge`.

So I'm confused here, and maybe you can enlighten me. As I read this documentation, --merge would always force a merge, like --no-ff. If so, I don't see an option to preserve the existing behavior, which is the I-don't-care-just-do-it case. If the behavior is different, then this documentation needs to be improved, I think, along with the documentation earlier in the series.

-- 
brian m. carlson / brian with sandals: Houston, Texas, US
+1 832 623 2791 | http://www.crustytoothpaste.net/~bmc | My opinion only
OpenPGP: RSA v4 4096b: 88AC E9B2 9196 305B A994 7552 F1BA 225C 0223 B187
Previous: Felipe ContrerasNext: Felipe Contreras
Message 10 of 18 in “Reject non-ff pulls by default”
  1. 0/7 Reject non-ff pulls by defaultFelipe Contreras, May 2, 2014
  2. 1/7 pull: rename pull.rebase to pull.modeFelipe Contreras, May 2, 2014
  3. W. Trevor KingMay 2, 2014
  4. Richard HansenMay 2, 2014
  5. Felipe ContrerasMay 2, 2014
  6. Richard HansenMay 2, 2014
  7. 2/7 pull: migrate all the tests to pull.modeFelipe Contreras, May 2, 2014
  8. 3/7 pull: refactor $rebase variable into $modeFelipe Contreras, May 2, 2014
  9. 4/7 pull: add --merge optionFelipe Contreras, May 2, 2014
  10. brian m. carlsonMay 2, 2014
  11. Felipe ContrerasMay 2, 2014
  12. brian m. carlsonMay 2, 2014
  13. Felipe ContrerasMay 2, 2014
  14. brian m. carlsonMay 2, 2014
  15. 5/7 pull: add merge-ff-only optionFelipe Contreras, May 2, 2014
  16. W. Trevor KingMay 2, 2014
  17. 6/7 pull: add warning on non-ff mergesFelipe Contreras, May 2, 2014
  18. 7/7 pull: only allow ff merges by defaultFelipe Contreras, May 2, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.